Nginx Admin version 1.4 released.

The Nginx Admin WHM plugin v1.4 is released.

Change Log:
1- cPanel 11.28 install issue solved.
2- Apache Status issue solved.
3- 413 Request Entity Too Large issue solution added.

Please do the following to install!

Install instruction:
cd /usr/local/src
wget http://nginxcp.com/nginxadmin1.4-stable.tar
tar xf nginxadmin1.4-stable.tar
cd publicnginx
./nginxinstaller install

Note:If you have previously installed the any version of the nginx, please uninstall and then perform the installation.

Uninstall instruction is given below,

cd /usr/local/src
wget http://nginxcp.com/nginxadmin1.4-stable.tar
tar xf nginxadmin1.4-stable.tar
cd publicnginx
./nginxinstaller uninstall

Incoming search terms:

  • nginx admin

22 comments

  • Sorry for the repost, but this issue is with NginxCP 1.4:

    I tried setting apache to port 8080 before installing NginxCP and everything installed fine, but every website resulted in the following error:

    Ok, error:
    502 Bad Gateway
    Nginx

    I can’t wait to test this, please let me know if you need more info.

    Thanks for all of your hard work!

    • admin

      You nothing need to change any port.
      The installer will do automatically, You just need to install as per provided method.
      The issue is with your setting.
      How site will work when script using port 8081 and you have set 8081?

      Just uninstall and reinstall and don’t change any port.
      The Apache port should be 80 before install.

  • Update:

    I uninstalled, and reinstalled without first changing the Apache port to 8080 and everything works fine.

    I ran apachebenchmark, but this time, i did now find the speed increases I had previously reported when using NginxCP 1.2

    Actually, I’m getting the same benchmarks as when using only Apache???

    :-(

    I’ve verified Nginx Service Status: up, and Apache Port modified to port 8081

  • Actually my latest test showed:

    Apache + Nginx:
    123 req/sec

    Apache Only:
    163 req/sec

    when my test on the same hardware setup with NginxCP 1.2 benchmarked:
    924 req/sec

    Not sure what changed, but performance was much better with NginxCP 1.2

    • admin

      The only change in Nginx Admin adding cPanel 11.28 capability, added below in nginx.conf
      client_max_body_size 4M;
      client_body_buffer_size 128k;

      The change in benchmarked maybe due to latest cpanel 11.28

  • Error: “Please update cPanel to version 11.25 or above”

    Burt I have version 11.26.20 on my VPS and the Nginx Admin 1.3 work fine.

    Yes, I unistall 1.3 before try install 1.4.

  • Fotis Evangelou

    The latest 1.4 release of NginxCP has a small bug in the installer file where you check the version. It checks if you have 11.28 and then prompts to upgrade to 11.25. So you should probably want to change the messages there.

    Additionally, I’ve taken the time and improved the page within WHM/cPanel, to make it more user friendly and added a couple of things. Here is the screenshot I uploaded recently:

    If you want to add the code (it’s just the addon_nginx.cgi, nginx.php and 1 image file), just contact me back.

    • admin

      The Latest Nginx Admin Installer prompts “Upgrade to 11.25 or later”
      Good to see your improved interface. We always welcome to all develpers in Nginx Admin Project.
      Please send me in zip format via email at 9xlinux@live.com so I can check and release in next update.

  • Hi,
    during reboot, when httpd service is starting I get the following error messages. Everything is working fine, but this error happens for every domain on the server, just curious how to fix it.
    *******
    Starting httpd: Starting nginx daemon: nginx[warn]: conflicting server name “173.208.123.38” on 173.208.123.38:80, ignored
    [warn]: conflicting server name “173.208.123.38” on 173.208.123.38:80, ignored

  • Great. Thanks. I also wrote in about the performance difference I benchmarked between NginxCP 1.2 and NginxCP 1.4

    I found NginxCP 1.2’s Performance much, much higher than NginxCP1.4, anything we can do?

    Thanks again.

  • Dodli

    hi
    are any changes needed or suggested for using on a VPS?

  • Mix

    Hi
    nginx setup I get an error like this. Nginx is active but does not open sites.

    Generating vhosts…
    Traceback (most recent call last):
    File “/scripts/createvhosts.py”, line 163, in ?
    sublist = ydata[‘sub_domains’]
    KeyError: ‘sub_domains’
    Installing WHM interface…
    deploying booster rockets
    gettin there
    update apache logsconfigure
    Installation Complete — run /etc/init.d/httpd restart to start nginx

    • admin

      This is issue with some build of cPanel current.
      First uninstall Nginx Admin.
      Try upgrade to cPanel via commad line /scripts/upcp –force
      Then reinstall again
      The cPanel build should be current

  • This is issue with some build of cPanel current.
    First uninstall Nginx Admin.
    Try upgrade to cPanel via commad line /scripts/upcp –force
    Then reinstall again
    The cPanel build should be current

Leave a Reply

Your email address will not be published. Required fields are marked *


*